Как выделить дубликаты в Google Таблицах в 2022 году [2 Ways Explained]

Таблицы Excel всегда были основой огромных наборов данных. Они позволяют вам легко и автоматически управлять различными записями, обеспечивая при этом возможность использования функций, формул и всех других функций, предлагаемых электронными таблицами.

Хотя электронные таблицы хороши в своем отношении, они не могут предотвратить дублирование записей. Это означает, что вам придется вручную находить и заботиться о них самостоятельно, когда это необходимо.

Хотя удалять дубликаты в Google Таблицах легко, как насчет их выделения? Давайте узнаем!

Как выделить дубликаты в Google Таблицах: пошаговое руководство с картинками

Мы будем использовать условное форматирование в наших интересах, чтобы найти и выделить дубликаты в Google Sheets.

Следуйте любому из приведенных ниже руководств в зависимости от вашего текущего устройства и требований.

Способ 1. Используйте условное форматирование на настольных устройствах.

Условное форматирование позволяет применить форматирование к определенным ячейкам, содержащим данные, относящиеся к определенной вами формуле.

Вы можете использовать это в своих интересах, чтобы найти и применить выделение только к повторяющимся ячейкам в текущем листе.

Следуйте любому из приведенных ниже руководств, чтобы помочь вам в этом процессе.

СЧЁТЕСЛИ — это формула, которую мы будем использовать для выделения дубликатов на нашем листе. Следуйте одному из разделов ниже в зависимости от диапазона ваших данных.

1.1 Для одного столбца

Если вы хотите выделить дубликаты в одном столбце, вы можете использовать приведенную ниже формулу. Выполните следующие шаги, чтобы помочь вам в этом процессе.

=СЧЁТЕСЛИ(М:М,М1)>1

M:M — это ваш диапазон, а M1 — критерий. Если вы знакомы с формулами, вы можете скопировать и вставить приведенную выше формулу и использовать ее в своей таблице Google. Если нет, то начните с перехода к соответствующему листу.

Используйте клавишу Shift на клавиатуре или метку столбца вверху, чтобы выбрать столбец, в котором вы хотите искать дубликаты.

Теперь нажмите «Формат» в верхней части панели инструментов.

Нажмите и выберите «Условное форматирование».

Выбранный вами диапазон теперь будет автоматически добавлен на боковую панель условного форматирования слева от вас. Щелкните следующее раскрывающееся меню «Правила формулы» и выберите «Пользовательская формула».

Теперь скопируйте и вставьте формулу в новое место. Вы также можете использовать ссылку ниже для удобства.

=СЧЁТЕСЛИ(М:М,М1)>1

Замените M на первую ячейку вашего диапазона, а затем на следующую на последнюю ячейку в вашем диапазоне. Остальную часть формулы редактировать не нужно, и теперь к дубликатам слева следует применить выделение.

Вы можете изменить цвет выделения/заливки для повторяющихся ячеек, используя средство выбора на боковой панели.

Нажмите «Готово», чтобы завершить и сохранить правило.

Вот и все! Вот как вы можете выбрать дубликаты в определенном столбце в Google Таблицах.

1.2 Для нескольких столбцов

Если вы хотите найти и выделить повторяющиеся ячейки в нескольких столбцах, вы можете вместо этого использовать руководство, указанное ниже. Давайте начнем!

Откройте соответствующий лист и выберите несколько столбцов на своем листе, где вы хотите идентифицировать и выделить дубликаты. Вы можете щелкнуть и перетащить на экран или использовать клавиатуру. Вы также можете вручную определить свой диапазон и полностью пропустить этот шаг.

Нажмите «Формат» на панели инструментов вверху.

Выберите «Условное форматирование».

Теперь щелкните раскрывающееся меню и выберите «Пользовательская формула».

Введите нужную формулу в следующем синтаксисе

=СЧЁТЕСЛИ(M$1:N$1;O1)>1

Замените M & N номером ячейки нужных вам столбцов. Точно так же замените O1 вашими критериями поиска дубликатов.

Дубликаты теперь будут автоматически выделены цветом по умолчанию.

Вы можете изменить то же самое, нажав на средство выбора на панели инструментов внизу.

Вот и все! Теперь у вас будут выделены дубликаты в нескольких столбцах в вашей таблице Google.

Советы по поиску в нескольких столбцах

Google Sheets использует символ $ для определения абсолютных столбцов и строк. Это означает, что если вы хотите выделить дубликаты из значения одного столбца или нескольких значений столбца, этот символ может пригодиться.

Имейте в виду, вам нужно будет использовать это перед значением диапазона, чтобы определить абсолютный столбец. Используйте приведенный ниже пример для дальнейшего справки.

=СЧЁТЕСЛИ(M$1:P$1,$O1)>1

В приведенном выше примере мы найдем дубликаты из заданного диапазона на основе абсолютных значений, содержащихся в столбце O.

Способ 2: использовать условное форматирование на Android

Вы также можете использовать условное форматирование на устройствах Android. Следуйте приведенному ниже руководству, чтобы применить условное форматирование к листу, чтобы выделить повторяющиеся записи.

2.1 Для одного столбца

Откройте приложение Google Sheets на своем устройстве и нажмите на ячейку, чтобы выбрать ее.

Теперь перетащите один из углов, чтобы выбрать нужный диапазон.

После того, как вы выбрали диапазон, нажмите значок «Параметры формата» вверху.

Прокрутите вниз и нажмите «Условное форматирование».

Нажмите «Добавить» в правом верхнем углу.

Выбранный диапазон теперь будет автоматически введен для вас. Нажмите на раскрывающееся меню и выберите «Пользовательское правило».

Теперь используйте следующую формулу, чтобы найти дубликаты в выбранном диапазоне.

=СЧЁТЕСЛИ(M1:M10,M1)>1

Замените M1 на адрес первой ячейки в вашем столбце, а затем M10 на адрес последней ячейки в выбранном столбце. Замените M1 на желаемый критерий, но мы рекомендуем установить его в первую ячейку вашего столбца, если только вы не имеете дело с пустыми ячейками. Выберите свой стиль форматирования, нажав на одну из предустановок.

Вы также можете установить собственный стиль, нажав «+».

Когда вы закончите, нажмите «Сохранить» в правом верхнем углу.

Используйте жест «назад», чтобы вернуться к выбранному листу, если это необходимо, и теперь условное форматирование уже должно быть применено к выбранному диапазону. Теперь вы можете продолжить поиск дубликатов в других столбцах и строках.

2.2 Для нескольких столбцов

Вы можете использовать следующий синтаксис при поиске дубликатов в нескольких столбцах. Это то же самое, что и формула, используемая на настольных устройствах, и если вам нужна помощь с ее запуском, вы можете использовать приведенное выше руководство, которое поможет вам в этом процессе.

=СЧЁТЕСЛИ(M$1:N$1;O1)>1

Как обычно, замените M$1 на первую ячейку вашего диапазона, а N$1 на последнюю ячейку вашего диапазона. Убедитесь, что вы сохранили символ $ для определения абсолютов.

Наконец, замените O1 собственным критерием в зависимости от набора данных, который вы оцениваете.

Как удалить дубликаты в Google Sheets

Теперь, когда вы нашли дубликаты, хотите ли вы их удалить? Вот как вы можете сделать это в Google Таблицах.

Откройте Google Таблицы и выберите нужный диапазон, из которого вы хотите удалить дубликаты.

Теперь нажмите «Данные» на панели инструментов вверху.

Нажмите и выберите «Очистка данных».

Теперь нажмите «Удалить дубликаты».

Установите флажок «Выбрать все» и соответствующие столбцы в вашем диапазоне. Это также дает вам возможность выборочного исключения определенных столбцов из этого процесса.

Сделав свой выбор, нажмите «Удалить дубликаты».

Теперь дубликаты будут удалены из выбранного столбца. Нажмите «ОК», чтобы сохранить изменения и продолжить редактирование листа по мере необходимости.

Часто задаваемые вопросы

Вот несколько часто задаваемых вопросов о выделении дубликатов в Google Sheets, которые должны помочь вам быстро ознакомиться с последней информацией.

Устранение неполадок с результатами

Если вы новичок в использовании условного форматирования и формул в Google Таблицах, это может быть довольно пугающим, особенно если ваши формулы не могут показать вам предполагаемые результаты.

Вот несколько вещей, которые вы должны проверить, чтобы устранить неполадки с результатами при попытке выделить дубликаты в Google Таблицах.

  • Проверьте свой диапазон
  • Проверить абсолютные значения
  • Проверьте свой критерий
  • Переменные COUNTIF и UNIQUE не чувствительны к регистру.

  • Убедитесь, что данные в ячейках поддерживаются для условного форматирования.
  • Проверьте наличие пропущенных пробелов
  • Проверить неправильный синтаксис

Можно ли использовать условное форматирование на устройствах iOS?

К сожалению, приложения Google обычно имеют ограниченную поддержку устройств iOS, и это относится и к Google Sheets. Вы не можете использовать условное форматирование в приложении Google Sheets для iOS.

Мы рекомендуем вам переключиться на настольное устройство или использовать мобильный браузер на основе хрома, чтобы принудительно использовать настольный веб-сайт для Google Sheets на вашем мобильном устройстве.

Возможно, вам придется попробовать несколько браузеров, чтобы найти тот, который лучше всего работает с масштабированием.

Можете ли вы вместо этого выделить уникальные предметы?

Нет, к сожалению, формула UNIQUE в настоящее время не поддерживается условным форматированием, что означает, что вы не можете использовать ее для выделения уникальных элементов. Вы можете использовать его только для получения результатов в пустой ячейке/столбце.

Что делать, если вы ищете данные, которые повторяются 3 или 4 раза?

В синтаксисе COUNTIF мы используем символ >, чтобы определить, сколько раз набор данных повторяется в выбранном диапазоне. Таким образом, если вы хотите найти записи, повторяющиеся три или даже четыре раза, вы можете заменить 1 на желаемое число.

Например, если вы ищете записи в столбце B, которые повторяются четыре раза для первых 100 строк, вы будете использовать следующий синтаксис.

=СЧЁТЕСЛИ(B1:B100;B1)>4

Примечание. В результат также будут включены записи, которые повторяются более 4 раз в выбранном диапазоне.

Мы надеемся, что этот пост помог вам выделить дубликаты в Google Таблицах. Если у вас возникнут какие-либо проблемы или у вас есть дополнительные вопросы к нам, не стесняйтесь обращаться к нам, используя раздел комментариев ниже.

СВЯЗАННЫЙ:

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.